Troubleshooting Browser Problems

Is your Web browser compatible with Blackboard? Go to Blackboard’s Student & Faculty Resource Center to check Blackboard’s browser compatibility chart.

Java Must Be Installed and Enabled

You must have the most recent version of Java Runtime Environment to allow interactive elements to run properly on your computer. Visit the Java website to learn more.

Java is enabled by default on all supported browsers. If you have problems with the interactive elements of your courses, go to the instructions for enabling Java.

Cookies Must Be Enabled

Third-party cookies are enabled by default on all supported browsers. If you have difficulty staying logged into Blackboard, check browser settings to make sure that you allow third-party cookies. 
Firefox 
Internet Explorer

Pop-up Blockers Must Be Disabled

If you have difficulty downloading links or viewing discussion posts or quiz windows in Blackboard, you may need to disable pop-up blockers on your Wake Tech Blackboard website. 
Firefox 
Internet Explorer

Third-Party Plug-ins May Need To Be Installed

Some courses require the installation of third-party plug-ins, such as Adobe Flash, Windows Media Player, and others. In these cases, you will be notified and given a link to the required plug-in.